mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   GMP-ECM (https://www.mersenneforum.org/forumdisplay.php?f=55)
-   -   ecmpi with openmpi on Ubuntu? (https://www.mersenneforum.org/showthread.php?t=23487)

EdH 2018-07-04 20:17

ecmpi with openmpi on Ubuntu?
 
I'm trying to install and test ecmpi by Cyril Bouvier on my linux machines, but I keep getting messages that MPI_C can't be found. I've installed openmpi-bin and -common and all the dependencies, but none of the additional apt-get suggested items.

I also tried installing mpi (with and without openmpi), but still no joy.

Any suggestions?

EdH 2018-07-05 02:00

Solved!
 
I needed libopenmpi-dev. It was not a suggested file in the list from apt-get.

EdH 2020-10-05 16:25

I have posted elsewhere that openmpi would not work (at least for me) with Ubuntu 18.04 LTS. I was never able to get it running with either the repository version or the versions directly from open-mpi.org. Subsequently, I was not able to use Ubuntu 18.04 machines in my ecmpi cluster.

I am happy to report that I have been successful in getting the latest (4.0.5) version of openmpi working on machines that have been upgraded to Ubuntu 20.04 LTS. I still could not get the repository version to work for me and the 20.04 machines will not work with the 16.04 currently running cluster. However, since the 20.04 machines are working among themselves, it at least seems that I will be able to upgrade all the others and still have a working ecmpi cluster for my projects when the upgrades are all complete.

I will eventually edit my "How I Install and Run ecmpi. . ." page to reflect the changes.


All times are UTC. The time now is 10:46.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.