mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   Multiple systems/multiple CPUs. Best configuration? (https://www.mersenneforum.org/showthread.php?t=313)

BillW 2003-01-21 19:53

Multiple systems/multiple CPUs. Best configuration?
 
I have been involved in this project for a number of years (User:Whitney). Just recently, I decided to use some excess cycles on other system. Since these systems (all Linux) all have my home directory mounted via NFS I thought I could run mprime on each system and redirect the output to system specific directories using the following script:
----------------------------------------------------
#!/bin/sh
if [ ! -d ./`hostname` ]; then
mkdir `hostname`
fi

CPUS=`grep vendor_id /proc/cpuinfo -c`

while [ $CPUS != 0 ]; do
./mprime -w`hostname` -b -a$CPUS
CPUS=`expr $CPUS - 1`
done
---------------------------------------------------------

All that I do is log onto the target system and run the script. The correct number of processes are started depending on the number of CPU's.

It's not clear if this is the correct technique and that all the work is credited to my account. None of the system specific ini files have any info regarding my account, although there is a prime.ini file in the parent directory that was created when I was only running mprime from that single directory.

The files that are contained in the host specific directory for a dual cpu system are:

[root@dtl8a223 eng17264.adv.eng]# ls -la
total 80
drwxr-xr-x 2 wwhitney media 512 Jan 21 14:45 .
drwxrwxr-x 5 wwhitney media 1024 Jan 21 14:32 ..
-rw-r--r-- 1 wwhitney media 173 Jan 21 14:24 loca0001.ini
-rw-r--r-- 1 wwhitney media 173 Jan 21 14:24 loca0002.ini
-rw-r--r-- 1 wwhitney media 92 Jan 21 14:24 prim0001.ini
-rw-r--r-- 1 wwhitney media 172 Jan 21 14:24 prim0001.log
-rw-r--r-- 1 wwhitney media 92 Jan 21 14:24 prim0002.ini
-rw-r--r-- 1 wwhitney media 172 Jan 21 14:24 prim0002.log
-rw-r--r-- 1 wwhitney media 19 Jan 21 14:24 work0001.ini
-rw-r--r-- 1 wwhitney media 19 Jan 21 14:24 work0002.ini
[root@dtl8a223 eng17264.adv.eng]#
Do I have these systems configured properly or should I be doing something different?

Thanks, Bill

garo 2003-01-21 20:11

Instead of the prime.ini and local.ini for a dual sytem prim0001.ini and loca0001.ini etc are created. Make sure that the Username and password are correctly set to your username in the prim0001.ini and prim0002.ini files. Also, make sure the computer ID is correctly set in the loca0001.ini and 0002 files. Then all these systems should show up under your individual account report.

Otherwise the setup looks good.


All times are UTC. The time now is 06:55.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.