mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   CADO-NFS (https://www.mersenneforum.org/forumdisplay.php?f=170)
-   -   CADO help (https://www.mersenneforum.org/showthread.php?t=22725)

henryzz 2017-11-19 11:28

CADO help
 
I have just compiled CADO on WSL. I get an error when running:
[CODE]Info:root: Using default parameter file ./parameters/factor/params.c105
Info:root: No database exists yet
Info:root: Created temporary directory /tmp/cado.07ke7ttm
Info:Database: Opened connection to database /tmp/cado.07ke7ttm/c105.db
Info:root: Set tasks.threads=8 based on detected logical cpus
Info:root: tasks.polyselect.threads = 2
Info:root: tasks.sieve.las.threads = 2
Info:root: slaves.scriptpath is /mnt/e/Downloads/cado-nfs-2.3.0
Info:root: Command line parameters: ./cado-nfs.py 11111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111111
Info:root: If this computation gets interrupted, it can be resumed with ./cado-nfs.py /tmp/cado.07ke7ttm/c105.parameters_snapshot.0
Info:Server Launcher: Not adding JIMMY to whitelist (cannot be resolved), clients will only be allowed to connect on 127.0.0.1
Error:HTTP server: Exception trackback: [Errno -2] Name or service not known
Error:HTTP server: (end of Exception trackback)[/CODE]

I am fairly certain this is a fairly easy error to fix if you know how to. Anyone know how to?

Dubslow 2017-11-19 17:55

[QUOTE=henryzz;472107]
Info:Server Launcher: Not adding JIMMY to whitelist (cannot be resolved), clients will only be allowed to connect on 127.0.0.1
Error:HTTP server: Exception trackback: [Errno -2] Name or service not known
[/CODE]
[/QUOTE]

Looks like you have some misconfigured networking settings. Review the documentation for how to set up multiple computers (including how to only use the local machine).

(Unfortunately I can't be more specific, don't have CADO installed myself currently)

henryzz 2017-11-20 09:31

I am not having any joy. I can't even start it as a stand alone server.

xilman 2017-11-20 11:31

[QUOTE=henryzz;472153]I am not having any joy. I can't even start it as a stand alone server.[/QUOTE]I will get back to you later. CADO works fine here but I don't, at present, because I've a bad migraine now. :sick:

henryzz 2017-11-20 15:14

I just found a way of fixing it. It had to edit /etc/hosts to add 127.0.0.1 JIMMY
I found this by getting a similar error running sudo
Hope you lose your migraine quickly they can be a pain.

I am not certain that it should have been crashing after failing to resolve JIMMY. It knew it could use 127.0.0.1

I was right it was trivial to fix assuming you knew the issue.


All times are UTC. The time now is 04:25.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.