-   GPU Computing (
-   -   CUDA Toolkit for OpenSUSE 11.2--gcc 4.5 and up are not supported (

patrik 2011-09-20 20:12

CUDA Toolkit for OpenSUSE 11.2--gcc 4.5 and up are not supported
I'm trying to compile mfaktc for my new graphics card. I'm using OpenSUSE Linux 11.4, so I tried to install CUDA Toolkit for OpenSUSE 11.2. But when I compile mfaktc I get:[CODE]pjoh@linux-j6ed:~/mfaktc-0.17/src> make
/usr/local/cuda/bin/nvcc -I/usr/local/cuda/include/ --ptxas-options=-v --generate-code arch=compute_11,code=sm_11 --generate-code arch=compute_20,code=sm_20 --compiler-options=-Wall -c -o tf_72bit.o
In file included from /usr/local/cuda/include/cuda_runtime.h:59:0,
from <command-line>:0:
/usr/local/cuda/include/host_config.h:82:2: error: #error -- unsupported GNU version! gcc 4.5 and up are not supported!
make: *** [tf_72bit.o] Fel 1
pjoh@linux-j6ed:~/mfaktc-0.17/src> gcc --version
gcc (SUSE Linux) 4.5.1 20101208 [gcc-4_5-branch revision 167585]
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
What is the best way to resolve this? Downgrading to OpenSUSE 11.2? Or install a CUDA toolkit for a different Linux distribution on my OpenSUSE computer?

If I downgrade, is there a risk that my hardware won't be supported? I'm using a Core i5 2500K on an ASUS P8P67 LE and graphics card ASUS Geforce GTX 560 DC 1GB.

Christenson 2011-09-20 21:44

IIRC, this had to do with internal debug data for tools used by nvidia.

Unless you are into detailed debugging of mfaktc, I don't think it will matter if you comment out the #error directive.

patrik 2011-09-21 04:36

Thanks. It compiled alright. I'll try to run it when I get home from work this evening.

Dubslow 2011-09-21 06:55

I tried commenting out the error lines, and it then compiled, but didn't run. If yours doesn't, you can either install an older version of the gcc, or download a current mfaktc compiled in CUDA 3.2 here:[url][/url]

I got my tarball from a different place, but I'm pretty sure it's identical to the link above. Or, if your version runs, please let me know how you did it.

patrik 2011-09-21 18:30

Both my compiled executable and the one downloaded from your link give the following error:[CODE]pjoh@linux-j6ed:~/mfaktc-0.17> ./mfaktc.exe -st
mfaktc v0.17 (64bit built)

cudaSetDevice(0) failed
cudaGetLastError() returned 38: no CUDA-capable device is detected[/CODE]
There was a file, Developer Drivers for Linux (270.41.19), on the NVIDIA CUDA download page. The first time I tried to install it, my screen went blank, and I had to run parts of the Linux installation again before I got it to work again. The next time I tried to install it, I got a message that it was already installed.

Is Developer Drivers for Linux something that should be installed with CUDA, and could a corrupt installation be the problem?

Christenson 2011-09-22 00:18

I don't recall needing developer drivers...just regular ones.

But I do recall having to install the CUDA toolkit from Nvidia, and drivers for the card.

RichD 2011-09-27 00:25

I'm running:

OpenSUSE 11.4
gcc 4.5.1
nVidia Driver 280.13
mfaktc 0.17
CUDA Toolkit 4.0

No problems. I'm getting about 190-200M/s (if those are good numbers) using i5 and GTX 460.

Two points.

1. Make sure you use driver 280.xx
2. Comment out the error message as mentioned above.

Dubslow 2011-09-27 00:44

Yes, very good numbers. 1G or 768M 460? I have the latter at a 12% overclock and get 205M/s with full cpu support, 170-185M/s when I set the affinity to the equivalent of one P95 thread.

patrik 2012-01-16 06:55

I finally managed to get the installation working. The problem I had before was that I didn't manage to uninstall the noveau video driver that openSuse 11.4 was using.

On the nvidia driver download page, I finally found an additional information tab which had a link to a howto for suse users. That howto explained that there was a software repository at (/opensuse/11.4) that could be used instead of the .run file. Then I installed the packages the usual way using Yast.

Then I rebooted to get the old driver out of the kernel. After that I installed the GPU Computing SDK. When compiling the examples included I had the same problems again (mentioned in the first post) regarding gcc-4.5 and solved it just as Christenson suggested. After creating a missing link[CODE] ->[/CODE]in /usr/lib64, I managed to compile enough of the tests for the SDK to verify the installation (though it still failed missing mpi.h later).

The documentation file at Cuda Toolkit, CUDA_C_Getting_Started_Linux.pdf, was also very helpful.

RichD 2012-04-07 03:50

I've also found a How To guide at:


All times are UTC. The time now is 06:21.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.