mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   Software error or hardware error (https://www.mersenneforum.org/showthread.php?t=14886)

GuloGulo 2011-01-18 15:42

Software error or hardware error
 
Hi,
I'm running mprime 25.11 64-bit on ubuntu 10.04 and today mprime crashed after finding a factor in P1. This has happened several times before, but since I was running in menu mode I got some extra info.
[CODE][FONT=Courier New, monospace][SIZE=2]GuloGulo/Phenom_II_X6_1055T, M53619337 has a factor: 3068239623794576992633, AID: E7349195353FF153379E68612A21F119[/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2][Comm thread Jan 18 14:17][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2][Comm thread Jan 18 14:17] PrimeNet success code with additional info:[/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2][Comm thread Jan 18 14:17] CPU credit is 5.0082 GHz-days.[/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]*** glibc detected *** ./mprime: free(): invalid next size (fast): 0x0000000001f94d10 ***[/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]======= Backtrace: =========[/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]/lib/libc.so.6(+0x775b6)[0x7f5baf60b5b6][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]/lib/libc.so.6(cfree+0x73)[0x7f5baf611e83][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]./mprime[0x426b2d][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]./mprime[0x429ff6][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]./mprime[0x4330be][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]./mprime[0x4331cb][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]./mprime[0x44770a][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]/lib/libpthread.so.0(+0x69ca)[0x7f5bafd389ca][/SIZE][/FONT]
[FONT=Courier New, monospace][SIZE=2]/lib/libc.so.6(clone+0x6d)[0x7f5baf67a70d][/SIZE][/FONT]
[/CODE]My machine is a Phenom II X6 1055T overclocked to 3.645GHz. It has been running with this overclock for months and I have never had any other errors than it crashing after finding a factor. Are these crashes still related to an overly ambitious overclock or could they be due to buggy software, libraries or mprime itself?

ckdo 2011-01-18 16:36

This is probably the infamous [URL="http://www.mersenneforum.org/showthread.php?t=12814"]mprime P-1 segfault bug[/URL] again, which has been around for ages.

GuloGulo 2011-01-18 21:22

OK, thanks for the quick reply! So there is nothing to do other than restart mprime? Is the bug that hard to track down?

Prime95 2011-01-19 00:36

I believe this bug is fixed in version 26. Try it.


All times are UTC. The time now is 03:28.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.