mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   Prime95 version 26.5 (https://www.mersenneforum.org/showthread.php?t=15224)

Prime95 2011-02-05 23:57

Prime95 version 26.5
 
Version 26.5 build 5 is ready for testing. This version fixes some bugs that were reported for 26.4.

Download links:
Windows: [url]ftp://mersenne.org/gimps/p95v265.zip[/url]
Windows 64-bit: [url]ftp://mersenne.org/gimps/p64v265.zip[/url]
Mac OS X: [url]ftp://mersenne.org/gimps/Prime95-MacOSX-265.zip[/url]
Linux: [url]ftp://mersenne.org/gimps/mprime265.tar.gz[/url]
Linux 64-bit: [url]ftp://mersenne.org/gimps/mprime265-linux64.tar.gz[/url]
FreeBSD: [url]ftp://mersenne.org/gimps/mprime265-FreeBSD.tar.gz[/url]
FreeBSD 64-bit: [url]ftp://mersenne.org/gimps/mprime265-FreeBSD64.tar.gz[/url]
Windows NT service: [url]ftp://mersenne.org/gimps/winnt265.zip[/url]
Windows NT service 64-bit: [url]ftp://mersenne.org/gimps/win64nt265.zip[/url]
Source: [url]ftp://mersenne.org/gimps/source265.zip[/url]

Bug fixes are described here: [url]http://mersenneforum.org/showpost.php?p=237200&postcount=2[/url]

Prime95 2011-02-05 23:58

1) Occasionally, P-1 stage 2 would report 100% complete before stage 2 completed. This bug has been around forever. I've finally found the cause! Fixed in 26.5 build 2.
2) Worktodo.txt was not updated properly when P-1 completed for a PRP test. Fixed in 26.5 build 3.
3) In 26.5 build 3, when benchmarking and measuring CPU speed the program will keep all cores busy by launching auxiliary threads that loop indefinitely. This should prevent Intel Turbo boost from kicking in. This should prevent cases where the CPU speed is reported as 1.87 GHz, yet a benchmark reports very fast timings because the CPU core has been boosted to 3.2 GHz because only one core is active.
4) In 26.5 build 3, the OS's mapping of hyperthreaded logical CPU numbers to physical CPUs is determined automatically at startup. The AffinityScramble setting (see undoc.txt) is no longer supported. It is replaced by the AffinityScramble2 setting.
5) In 26.5 build 3, the message "set affinity to run on any cpu" instead listed all the CPU numbers and as well as CPU #31. Fixed in build 4.
6) In 26.5 build 3 and 4, benchmarking a dual-core non-SSE2 machine will crash. Fixed in build 5.
7) KeepPminus1SaveFiles=0 option described in undoc.txt did not work when a factor was found. Fixed in 26.6.
8) The 32K,64K,80K length FFTs with sumout checking for Pentium 4's with 256K or less cache were not implemented. Symptom is a torture test failure. Fixed in 26.6.
9) Prime95 does not load on Sandy Bridge CPUs running Win XP. I've got a trial fix in 26.6.
10) Prime95 chooses very inefficient FFT implementations for Core 2 Celerons (they have 512K L2 cache). Working on a fix for for 26.6.
11) Logical CPU numbers were sometimes output zero-based and sometimes one-based. In 26.6, they are all one-based.

ixfd64 2011-02-06 00:39

whatsnew.txt needs to be updated.

ET_ 2011-02-06 11:53

Waiting for mprime and mprime_x86_64 :smile:

Luigi

tichy 2011-02-06 13:47

There is a r4delay3_p4tp.o file missing in the source archive, thus making own mprime build impossible.

This is my error message:
[CODE]wmigda@gentoo /home/scr2/000000000/cmake $ make
-- Build type: RELEASE
-- System Info:
SYSTEM_NAME: Linux
SYSTEM_PROCESSOR: i686
SYSTEM_VERSION: 2.6.34-gentoo-r6
-- Compiling for 32-bit system
-- Configuring done
-- Generating done
-- Build files have been written to: /home/scr2/000000000/cmake
[ 93%] Built target gwnum
Linking CXX executable mprime
gwnum/libgwnum.a(mult.o):(_GWDATA+0x2b7c): undefined reference to `xfft_r4delay_720K_2304_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x2e3c): undefined reference to `xfft_r4delay_960K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x2e48): undefined reference to `xfft_r4delay_960K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3020): undefined reference to `xfft_r4delay_1152K_4608_4_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3050): undefined reference to `xfft_r4delay_1152K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3200): undefined reference to `xfft_r4delay_1344K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x320c): undefined reference to `xfft_r4delay_1344K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x32b8): undefined reference to `xfft_r4delay_1440K_4608_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x32c4): undefined reference to `xfft_r4delay_1440K_4608_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3358): undefined reference to `xfft_r4delay_1536K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x33ec): undefined reference to `xfft_r4delay_1600K_5120_4_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x367c): undefined reference to `xfft_r4delay_2240K_5120_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3704): undefined reference to `xfft_r4delay_2304K_4608_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x38b4): undefined reference to `xfft_r4delay_2688K_3072_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3970): undefined reference to `xfft_r4delay_2880K_4608_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x39d4): undefined reference to `xfft_r4delay_3M_6144_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3a98): undefined reference to `xfft_r4delay_3200K_5120_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x3c34): undefined reference to `xfft_r4delay_3840K_6144_4_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x5b6c): undefined reference to `xfft_r4delay_1440K_ac_3840_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x5d70): undefined reference to `xfft_r4delay_2304K_ac_4608_2_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x5e7c): undefined reference to `xfft_r4delay_3M_ac_6144_4_P4TP'
gwnum/libgwnum.a(mult.o):(_GWDATA+0x5f78): undefined reference to `xfft_r4delay_3840K_ac_6144_4_P4TP'
collect2: ld returned 1 exit status
make[2]: *** [mprime] Błąd 1
make[1]: *** [CMakeFiles/mprime.dir/all] Błąd 2
make: *** [all] Błąd 2
[/CODE]EDIT: I see an improvement being made in the Linux makefiles: ,,$(shell pkg-config --static --libs libcurl)'' :) So, from now on the Linux chores shall become nonexistent ?

EDIT2: it looks that there are more '*tp.o' objects required&misssing, e.g. r4delay5_p4tp.o

Prime95 2011-02-06 14:43

[QUOTE=ET_;251516]Waiting for mprime and mprime_x86_64 [/QUOTE]

I'm working on that. I retired my Linux build boxes. I do have a Ubuntu box, but when I used that for 26.4 someone complained about a GLIBC_3.11(?) error.

The question is, should I go find older Linux versions to install using VirtualBox so that fewer users face library issues or should I assume most users upgrade their kernels frequently and GLIBC_3.11 is now commonplace?

tichy 2011-02-06 15:07

[QUOTE=Prime95;251528]The question is, should I go find older Linux versions to install using VirtualBox so that fewer users face library issues or should I assume most users upgrade their kernels frequently and GLIBC_3.11 is now commonplace?[/QUOTE]

Maybe two versions, just like for Win and WinNT ? If not, one can always do his/her own linux build for the older glibc/kernel setup.

Prime95 2011-02-07 15:53

The linux 64-bit version using GLIBC 3.11 is available.

I tried installing 32-bit Debian and soon descended into libcurl dependency hell. I'll wipe it clean and try installing an older version of Ubuntu. If that succeeds I'll create a VirtualBox with an older 64-bit Ubuntu to link to an older GLIBC.

Thanks for your patience.

NBtarheel_33 2011-02-07 17:11

What does "fixed in next release" mean? Fixed in v26.5 or not until v27?

And when will you be implementing the option for worktodo of "test only exponents guaranteed to yield Mersenne primes"? :P

tichy 2011-02-07 17:22

[QUOTE=Prime95;251664]I tried installing 32-bit Debian and soon descended into libcurl dependency hell.[/QUOTE]

So, what is the output of [FONT=Courier New]pkg-config --static --libs libcurl[/FONT] and what specificaly fails when attempting the build ?

henryzz 2011-02-07 19:44

Wasn't a static version version available for 24.14? Surely that would solve the problem for most people.


All times are UTC. The time now is 00:54.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.