mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   Software (https://www.mersenneforum.org/forumdisplay.php?f=10)
-   -   Newb help (it crashes) (https://www.mersenneforum.org/showthread.php?t=3448)

Proggie 2004-12-22 18:26

Newb help (it crashes)
 
Hi, I'm running Xandros 3.0 (which runs on some version of Debian), and I downloaded the debian package. It did the factoring correctly, then it says (I had to restart it to get the output because I had it in a startup script and I'm not sure where the output for that went):

Mersenne number primality test program version 23.9
Starting P-1 factoring on M34338919 with B1=405000, B2=8505000
Chance of finding a factor is an estimated 5.29%
M34338919 stage 1 complete. 14902 transforms. Time: 757.632 sec.
Starting stage 1 GCD - please be patient.
Stage 1 GCD complete. Time: 267.931 sec.
Segmentation fault

Any ideas? I tried sprime also, still a seg fault. I can give more info, just let me know what you need to solve this. Thank you!

Prime95 2004-12-22 19:36

Please try version 24.6, the link is buried in this thread:

[url]http://www.mersenneforum.org/showthread.php?t=3387[/url]

There was a rare memory corruption bug in the GCD code. I'm curious if this bug is the cause of your problem.

Proggie 2004-12-23 04:43

Well, it might be too early to say, but it seems to be working. It actually is producing some results. I'll repost to this thread if it dies again. thank you!

Jeff Gilchrist 2005-01-04 15:54

Hi George,

I just had the exact same problem with mprime 2.39 on FC3 with a new P4 3Ghz box. I tried upgrading to the beta build of 24.6 you post and it has finished stage 1 and is now onto stage 2 so I guess that did solve the problem.

Jeff.

MGT 2005-01-05 07:35

I was experiencing segmentation faults using version 23.9 on RHEL AS 3.0 after "Stage 1 GCD complete". I installed version 24.6 and it is now in Stage 2 and appears to be running OK. Thanks for the fix! :banana:


All times are UTC. The time now is 12:21.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.