mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   PrimeNet (https://www.mersenneforum.org/forumdisplay.php?f=11)
-   -   PrimeNet API moved? (https://www.mersenneforum.org/showthread.php?t=15789)

James Heinrich 2011-07-18 17:59

PrimeNet API moved?
 
According to the [url=http://v5.mersenne.org/v5design/v5webAPI_0.97.html]v5.0 PrimeNet Web API 0.97(c)[/url] specifications, the web API should be found at [url]http://v5.mersenne.org/v5/[/url]
But, alas, it is not found there... where did it go? :unsure:

James Heinrich 2011-07-26 11:30

100 views, but nobody knows the answer? :sad:

Prime95 2011-07-26 13:45

I followed the link on the side menu of mersenne.org. No problems accessing [url]http://v5.mersenne.org/v5design/v5webAPI_0.97.html[/url]

James Heinrich 2011-07-26 15:56

[QUOTE=Prime95;267575]I followed the link on the side menu of mersenne.org. No problems accessing [url]http://v5.mersenne.org/v5design/v5webAPI_0.97.html[/url][/QUOTE]Oh, there's no problem accessing the API specifications, but trying to access the [i]API[/i] itself, doesn't work for me. There's a number of example queries in that document (which I believe are intentionally broken with spaces to prevent unwanted spidering, so I won't quote them here), but if I go to any of them, or even the base [url]http://v5.mersenne.org/v5/[/url] I get 404 (not found).

Prime95 2011-07-26 23:15

If you run prime95, poke around in the Primenet dialog box. There is a setting to print out debug information. I believe this is the same as Debug=2 in the [Primenet] section of prime.txt. Anyway, this outputs the full http URLs that prime95 uses to communicate with the server.

James Heinrich 2011-07-27 11:22

Thanks. That shows me the correct location. Unfortunately I can't seem to get a useful response out of it, even using the example in section "5.9 ps - Ping Server" of the API docs. I get a blank response with a 405 (method not allowed). Am I doing something wrong (I assume yes)? Is this the place to discuss it?

ciic 2011-11-25 10:59

part2: CURL library error: Couldn't resolve host 'v5.mersenne.org'
 
Hi.
Got the error
[QUOTE][Comm thread Nov 25 05:53] Getting assignment from server
[Comm thread Nov 25 05:53] CURL library error: Couldn't resolve host 'v5.mersenne.org'
[Comm thread Nov 25 05:53] CURL library error: Couldn't resolve host 'v5.mersenne.org'
[Comm thread Nov 25 05:53] Visit [URL="http://mersenneforum.org/"]http://mersenneforum.org[/URL] for help.
[Comm thread Nov 25 05:53] Will try contacting server again in 70 minutes. [/QUOTE]

See my initial post here:

[URL]http://www.mersenneforum.org/showthread.php?p=279796#post279796[/URL]

Cheers!

Uncwilly 2011-11-25 17:47

[QUOTE=ciic;279797]Hi.
Got the error


See my initial post here:

[URL]http://www.mersenneforum.org/showthread.php?p=279796#post279796[/URL]

Cheers![/QUOTE]
The server may have been down for a moment when you tried to contact it.


All times are UTC. The time now is 12:26.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.